use strict;
my $str = '{ "claim1": "val1", "claim2": "val2" }';
my $regex = qr/(\"claim1\":)(.*?)\"(.*?)\"/mp;
my $subst = '$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";