using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"playground\[\?\(@\.playhouse\s*==\s*'true'\s+&&\s+@\.IsPoolAvailable\s*==\s*'true'\)\](\.\S+)\]";
string substitution = @"poolavailable$1";
string input = @".city.playground[?(@.playhouse == 'true' && @.IsPoolAvailable=='true')].checked]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}