import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "playground\\[\\?\\(@\\.playhouse\\s*==\\s*'true'\\s+&&\\s+@\\.IsPoolAvailable\\s*==\\s*'true'\\)\\](\\.\\S+)\\]";
final String string = ".city.playground[?(@.playhouse == 'true' && @.IsPoolAvailable=='true')].checked]";
final String subst = "poolavailable$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}