$re = '/playground\[\?\(@\.playhouse\s*==\s*\'true\'\s+&&\s+@\.IsPoolAvailable\s*==\s*\'true\'\)\](\.\S+)\]/';
$str = '.city.playground[?(@.playhouse == \'true\' && @.IsPoolAvailable==\'true\')].checked]';
$subst = "poolavailable$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;