const regex = /playground\[\?\(@\.playhouse\s*==\s*'true'\s+&&\s+@\.IsPoolAvailable\s*==\s*'true'\)\](\.\S+)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('playground\\[\\?\\(@\\.playhouse\\s*==\\s*\'true\'\\s+&&\\s+@\\.IsPoolAvailable\\s*==\\s*\'true\'\\)\\](\\.\\S+)\\]', 'g')
const str = `.city.playground[?(@.playhouse == 'true' && @.IsPoolAvailable=='true')].checked]`;
const subst = `poolavailable$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);