re = /playground\[\?\(@\.playhouse\s*==\s*'true'\s+&&\s+@\.IsPoolAvailable\s*==\s*'true'\)\](\.\S+)\]/
str = '.city.playground[?(@.playhouse == \'true\' && @.IsPoolAvailable==\'true\')].checked]'
subst = 'poolavailable$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result