import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\*\\*Hello, (.*)\\*\\*";
final String string = "**Hello, @${{ github.actor }}!**\n"
+ "**This component is critical!**\n"
+ "**Edit and input the following BEFORE approving the PR!**\n\n"
+ "*Description: XXXXXXXXXX\n"
+ "*Justification: XXXXXXXXXX\n\n"
+ "The last change was authored by:\n"
+ "@${{ github.event.pull_request.user.login }}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}