const regex = /\*\*Hello, (.*)\*\*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\*\\*Hello, (.*)\\*\\*', 'gm')
const str = `**Hello, @\${{ github.actor }}!**
**This component is critical!**
**Edit and input the following BEFORE approving the PR!**
*Description: XXXXXXXXXX
*Justification: XXXXXXXXXX
The last change was authored by:
@\${{ github.event.pull_request.user.login }}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}