// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\*\*Hello, (.*)\*\*").unwrap();
let string = "**Hello, @${{ github.actor }}!**
**This component is critical!**
**Edit and input the following BEFORE approving the PR!**
*Description: XXXXXXXXXX
*Justification: XXXXXXXXXX
The last change was authored by:
@${{ github.event.pull_request.user.login }}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}