$re = '/\*\*Hello, (.*)\*\*/m';
$str = '**Hello, @${{ github.actor }}!**
**This component is critical!**
**Edit and input the following BEFORE approving the PR!**
*Description: XXXXXXXXXX
*Justification: XXXXXXXXXX
The last change was authored by:
@${{ github.event.pull_request.user.login }}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);