package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{1,2}) ((д\.)|(дней)|(день))( назад)?`)
var str = `6 д.
23 д.
12 дней
61 день
15 дней назад
62 дней назад
5 ч
6 нед.
три минуты назад
час назад
два часа назад`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}