import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1,2}) ((д\\.)|(дней)|(день))( назад)?";
final String string = "6 д.\n"
+ "23 д.\n"
+ "12 дней\n"
+ "61 день\n"
+ "15 дней назад\n"
+ "62 дней назад\n\n"
+ "5 ч\n"
+ "6 нед.\n"
+ "три минуты назад\n"
+ "час назад\n"
+ "два часа назад";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}