import re
regex = re.compile(r"^((--(?P<HELP>help).*)|((?:-s|--separator)\s(?P<SEP>.*?)\s)?((?P<OP1>-?\d+))(\s(?P<OP2>-?\d+))?(\s(?P<OP3>-?\d+))?)$", flags=re.MULTILINE)
test_str = ("-s T 10\n"
"--help\n"
"3 13 2\n"
"--separator T 3 11\n"
"wrong argument\n"
"-s test1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")