re = /^((--(?P<HELP>help).*)|((?:-s|--separator)\s(?P<SEP>.*?)\s)?((?P<OP1>-?\d+))(\s(?P<OP2>-?\d+))?(\s(?P<OP3>-?\d+))?)$/m
str = '-s T 10
--help
3 13 2
--separator T 3 11
wrong argument
-s test1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end