#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9_-]{3,29}(,[a-zA-Z0-9_-]{3,29})*$"
Local $sString = "Valid examples:" & @CRLF & _
"" & @CRLF & _
"AutoModerator,sodypop,reddit,Announcements-ModTeam" & @CRLF & _
"sOdYpOp,AutoModerator" & @CRLF & _
"AutoModerator" & @CRLF & _
"" & @CRLF & _
"Invalid examples: " & @CRLF & _
"" & @CRLF & _
"/u/AutoModerator,/u/username" & @CRLF & _
"u/AutoModerator,u/username" & @CRLF & _
"AutoModerator, username" & @CRLF & _
"username,moderator,someone," & @CRLF & _
"username;moderator;someone" & @CRLF & _
"X,somesuperlongimpossibleusername,some?one"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")