// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9_-]{3,29}(,[a-zA-Z0-9_-]{3,29})*$").unwrap();
let string = "Valid examples:
AutoModerator,sodypop,reddit,Announcements-ModTeam
sOdYpOp,AutoModerator
AutoModerator
Invalid examples:
/u/AutoModerator,/u/username
u/AutoModerator,u/username
AutoModerator, username
username,moderator,someone,
username;moderator;someone
X,somesuperlongimpossibleusername,some?one";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}