use strict;
my $str = 'Valid examples:
AutoModerator,sodypop,reddit,Announcements-ModTeam
sOdYpOp,AutoModerator
AutoModerator
Invalid examples:
/u/AutoModerator,/u/username
u/AutoModerator,u/username
AutoModerator, username
username,moderator,someone,
username;moderator;someone
X,somesuperlongimpossibleusername,some?one';
my $regex = qr/^[a-zA-Z0-9_-]{3,29}(,[a-zA-Z0-9_-]{3,29})*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}