const regex = /^[a-zA-Z0-9_-]{3,29}(,[a-zA-Z0-9_-]{3,29})*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9_-]{3,29}(,[a-zA-Z0-9_-]{3,29})*$', 'gm')
const str = `Valid examples:
AutoModerator,sodypop,reddit,Announcements-ModTeam
sOdYpOp,AutoModerator
AutoModerator
Invalid examples:
/u/AutoModerator,/u/username
u/AutoModerator,u/username
AutoModerator, username
username,moderator,someone,
username;moderator;someone
X,somesuperlongimpossibleusername,some?one`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}