re = /^[a-zA-Z0-9_-]{3,29}(,[a-zA-Z0-9_-]{3,29})*$/m
str = 'Valid examples:
AutoModerator,sodypop,reddit,Announcements-ModTeam
sOdYpOp,AutoModerator
AutoModerator
Invalid examples:
/u/AutoModerator,/u/username
u/AutoModerator,u/username
AutoModerator, username
username,moderator,someone,
username;moderator;someone
X,somesuperlongimpossibleusername,some?one'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end