import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9_-]{3,29}(,[a-zA-Z0-9_-]{3,29})*$";
final String string = "Valid examples:\n\n"
+ "AutoModerator,sodypop,reddit,Announcements-ModTeam\n"
+ "sOdYpOp,AutoModerator\n"
+ "AutoModerator\n\n"
+ "Invalid examples: \n\n"
+ "/u/AutoModerator,/u/username\n"
+ "u/AutoModerator,u/username\n"
+ "AutoModerator, username\n"
+ "username,moderator,someone,\n"
+ "username;moderator;someone\n"
+ "X,somesuperlongimpossibleusername,some?one";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}