#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\((?!\s*SELECT\b)[^()]*\)"
Local $sString = "WITH test AS (" & @CRLF & _
" SELECT" & @CRLF & _
" DATE_DIFF(start_date, end_date, DAY)," & @CRLF & _
" DATE_DIFF(start_date" & @CRLF & _
" ,end_date" & @CRLF & _
" ,DAY)" & @CRLF & _
" FROM apple" & @CRLF & _
")" & @CRLF & _
",test 2 AS (" & @CRLF & _
" SELECT blah" & @CRLF & _
" FROM blah" & @CRLF & _
")" & @CRLF & _
"SELECT" & @CRLF & _
" *" & @CRLF & _
"FROM test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")