import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((?!\\s*SELECT\\b)[^()]*\\)";
final String string = "WITH test AS (\n"
+ " SELECT\n"
+ " DATE_DIFF(start_date, end_date, DAY),\n"
+ " DATE_DIFF(start_date\n"
+ " ,end_date\n"
+ " ,DAY)\n"
+ " FROM apple\n"
+ ")\n"
+ ",test 2 AS (\n"
+ " SELECT blah\n"
+ " FROM blah\n"
+ ")\n"
+ "SELECT\n"
+ " *\n"
+ "FROM test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}