$re = '/\((?!\s*SELECT\b)[^()]*\)/m';
$str = 'WITH test AS (
SELECT
DATE_DIFF(start_date, end_date, DAY),
DATE_DIFF(start_date
,end_date
,DAY)
FROM apple
)
,test 2 AS (
SELECT blah
FROM blah
)
SELECT
*
FROM test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);