using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?!\s*SELECT\b)[^()]*\)";
string input = @"WITH test AS (
SELECT
DATE_DIFF(start_date, end_date, DAY),
DATE_DIFF(start_date
,end_date
,DAY)
FROM apple
)
,test 2 AS (
SELECT blah
FROM blah
)
SELECT
*
FROM test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}