re = /\((?!\s*SELECT\b)[^()]*\)/m
str = 'WITH test AS (
SELECT
DATE_DIFF(start_date, end_date, DAY),
DATE_DIFF(start_date
,end_date
,DAY)
FROM apple
)
,test 2 AS (
SELECT blah
FROM blah
)
SELECT
*
FROM test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end