const regex = /\((?!\s*SELECT\b)[^()]*\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((?!\\s*SELECT\\b)[^()]*\\)', 'gm')
const str = `WITH test AS (
SELECT
DATE_DIFF(start_date, end_date, DAY),
DATE_DIFF(start_date
,end_date
,DAY)
FROM apple
)
,test 2 AS (
SELECT blah
FROM blah
)
SELECT
*
FROM test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}