#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bKEYWORD1\b(?:(?<=\bKeyWord2\b.*?)|(?=.*?\bKeyWord2\b))"
Local $sString = "KEYWORD1 is ahead of Keyword2" & @CRLF & _
"KEYWORD1 is ahead of Keyword2 and another KeyWord2" & @CRLF & _
"KeyWord2 is behind KEYWORD1" & @CRLF & _
"KEYWORD1 is ahead of KEYWORD1 and behind KeyWord2" & @CRLF & _
"KeyWord2 is twice of KeyWord2 and in the end KEYWORD1" & @CRLF & _
"KEYWORD1 is " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")