import re
regex = re.compile(r"\bKEYWORD1\b(?:(?<=\bKeyWord2\b.*?)|(?=.*?\bKeyWord2\b))", flags=re.MULTILINE)
test_str = ("KEYWORD1 is ahead of Keyword2\n"
"KEYWORD1 is ahead of Keyword2 and another KeyWord2\n"
"KeyWord2 is behind KEYWORD1\n"
"KEYWORD1 is ahead of KEYWORD1 and behind KeyWord2\n"
"KeyWord2 is twice of KeyWord2 and in the end KEYWORD1\n"
"KEYWORD1 is \n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")