import Foundation
let pattern = #"\bKEYWORD1\b(?:(?<=\bKeyWord2\b.*?)|(?=.*?\bKeyWord2\b))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
KEYWORD1 is ahead of Keyword2
KEYWORD1 is ahead of Keyword2 and another KeyWord2
KeyWord2 is behind KEYWORD1
KEYWORD1 is ahead of KEYWORD1 and behind KeyWord2
KeyWord2 is twice of KeyWord2 and in the end KEYWORD1
KEYWORD1 is
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)