import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bKEYWORD1\\b(?:(?<=\\bKeyWord2\\b.*?)|(?=.*?\\bKeyWord2\\b))";
final String string = "KEYWORD1 is ahead of Keyword2\n"
+ "KEYWORD1 is ahead of Keyword2 and another KeyWord2\n"
+ "KeyWord2 is behind KEYWORD1\n"
+ "KEYWORD1 is ahead of KEYWORD1 and behind KeyWord2\n"
+ "KeyWord2 is twice of KeyWord2 and in the end KEYWORD1\n"
+ "KEYWORD1 is \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}