re = /\bKEYWORD1\b(?:(?<=\bKeyWord2\b.*?)|(?=.*?\bKeyWord2\b))/m
str = 'KEYWORD1 is ahead of Keyword2
KEYWORD1 is ahead of Keyword2 and another KeyWord2
KeyWord2 is behind KEYWORD1
KEYWORD1 is ahead of KEYWORD1 and behind KeyWord2
KeyWord2 is twice of KeyWord2 and in the end KEYWORD1
KEYWORD1 is
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end