use strict;
my $str = 'KEYWORD1 is ahead of Keyword2
KEYWORD1 is ahead of Keyword2 and another KeyWord2
KeyWord2 is behind KEYWORD1
KEYWORD1 is ahead of KEYWORD1 and behind KeyWord2
KeyWord2 is twice of KeyWord2 and in the end KEYWORD1
KEYWORD1 is
';
my $regex = qr/\bKEYWORD1\b(?:(?<=\bKeyWord2\b.*?)|(?=.*?\bKeyWord2\b))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}