using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?'group'[\w]+)"": {\s*
((\s*""(?'value'[^""]+)"": ""(?'key'[^""]+)""(?:, *
)?)+)
},?";
string input = @"""g1"": {
""k1"": ""v1"",
""k2"": ""v2"",
""k3"": ""v3""
},
""g2"": {
""k4"": ""v4"",
""k5"": ""v5"",
""k6"": ""v6""
},
""g3"": {
""k7"": ""v7"",
""k8"": ""v8"",
""k9"": ""v9""
}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}