import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?'group'[\\w]+)\": \\{\\s*\n"
+ "((\\s*\"(?'value'[^\"]+)\": \"(?'key'[^\"]+)\"(?:, *\n"
+ ")?)+)\n"
+ "\\},?";
final String string = "\"g1\": {\n"
+ " \"k1\": \"v1\",\n"
+ " \"k2\": \"v2\",\n"
+ " \"k3\": \"v3\"\n"
+ "},\n"
+ "\"g2\": {\n"
+ " \"k4\": \"v4\",\n"
+ " \"k5\": \"v5\",\n"
+ " \"k6\": \"v6\"\n"
+ "},\n"
+ "\"g3\": {\n"
+ " \"k7\": \"v7\",\n"
+ " \"k8\": \"v8\",\n"
+ " \"k9\": \"v9\"\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}