const regex = /"(?'group'[\w]+)": {\s*
((\s*"(?'value'[^"]+)": "(?'key'[^"]+)"(?:, *
)?)+)
},?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(?\'group\'[\\w]+)": {\\s*
((\\s*"(?\'value\'[^"]+)": "(?\'key\'[^"]+)"(?:, *
)?)+)
},?', 'g')
const str = `"g1": {
"k1": "v1",
"k2": "v2",
"k3": "v3"
},
"g2": {
"k4": "v4",
"k5": "v5",
"k6": "v6"
},
"g3": {
"k7": "v7",
"k8": "v8",
"k9": "v9"
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}