$re = '/"(?\'group\'[\w]+)": {\s*
((\s*"(?\'value\'[^"]+)": "(?\'key\'[^"]+)"(?:, *
)?)+)
},?/';
$str = '"g1": {
"k1": "v1",
"k2": "v2",
"k3": "v3"
},
"g2": {
"k4": "v4",
"k5": "v5",
"k6": "v6"
},
"g3": {
"k7": "v7",
"k8": "v8",
"k9": "v9"
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);