# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|[^a-z])\((\d*|[a-z])\)/$1$2/gm;t' <<< "(x+2)/(x) -> only select ( ) in (x)
-(2)+. -> only select ( ) in (2)
(wsd). -> select nothing
(x)^2+2 -> only select ( ) in (x)
sin(x). -> select nothing
(22313)a. -> only select ( ) in (22313)
+23-3()/(3x)+(x). -> only select () in () and ( ) in (x)
sin(x)+3*x^2+(x)+23 -> only select ( ) in (x)"