import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[^a-z])\\((\\d*|[a-z])\\)";
final String string = "(x+2)/(x) -> only select ( ) in (x) \n"
+ "-(2)+. -> only select ( ) in (2)\n"
+ "(wsd). -> select nothing\n"
+ "(x)^2+2 -> only select ( ) in (x)\n"
+ "sin(x). -> select nothing\n"
+ "(22313)a. -> only select ( ) in (22313)\n"
+ "+23-3()/(3x)+(x). -> only select () in () and ( ) in (x)\n"
+ "sin(x)+3*x^2+(x)+23 -> only select ( ) in (x)";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}