using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[^a-z])\((\d*|[a-z])\)";
string substitution = @"$1$2";
string input = @"(x+2)/(x) -> only select ( ) in (x)
-(2)+. -> only select ( ) in (2)
(wsd). -> select nothing
(x)^2+2 -> only select ( ) in (x)
sin(x). -> select nothing
(22313)a. -> only select ( ) in (22313)
+23-3()/(3x)+(x). -> only select () in () and ( ) in (x)
sin(x)+3*x^2+(x)+23 -> only select ( ) in (x)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}