# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^|[^a-z])\((\d*|[a-z])\)"
test_str = ("(x+2)/(x) -> only select ( ) in (x) \n"
"-(2)+. -> only select ( ) in (2)\n"
"(wsd). -> select nothing\n"
"(x)^2+2 -> only select ( ) in (x)\n"
"sin(x). -> select nothing\n"
"(22313)a. -> only select ( ) in (22313)\n"
"+23-3()/(3x)+(x). -> only select () in () and ( ) in (x)\n"
"sin(x)+3*x^2+(x)+23 -> only select ( ) in (x)")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.