re = /(^|[^a-z])\((\d*|[a-z])\)/m
str = '(x+2)/(x) -> only select ( ) in (x)
-(2)+. -> only select ( ) in (2)
(wsd). -> select nothing
(x)^2+2 -> only select ( ) in (x)
sin(x). -> select nothing
(22313)a. -> only select ( ) in (22313)
+23-3()/(3x)+(x). -> only select () in () and ( ) in (x)
sin(x)+3*x^2+(x)+23 -> only select ( ) in (x)'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result