#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(https?:\/\/)?(www\.)?\w+\.(com|org|io)"
Local $sString = "http://www.google.com" & @CRLF & _
"www.google.com" & @CRLF & _
"google.com" & @CRLF & _
"telegram.org" & @CRLF & _
"egghead.io" & @CRLF & _
"w3schools.com" & @CRLF & _
"https://www.w3schools.com" & @CRLF & _
"https://www.typescriptlang.org"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")