// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(https?:\/\/)?(www\.)?\w+\.(com|org|io)").unwrap();
let string = "http://www.google.com
www.google.com
google.com
telegram.org
egghead.io
w3schools.com
https://www.w3schools.com
https://www.typescriptlang.org";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}