import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/)?(www\\.)?\\w+\\.(com|org|io)";
final String string = "http://www.google.com\n"
+ "www.google.com\n"
+ "google.com\n"
+ "telegram.org\n"
+ "egghead.io\n"
+ "w3schools.com\n"
+ "https://www.w3schools.com\n"
+ "https://www.typescriptlang.org";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}