const regex = /(https?:\/\/)?(www\.)?\w+\.(com|org|io)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/)?(www\\.)?\\w+\\.(com|org|io)', 'gmi')
const str = `http://www.google.com
www.google.com
google.com
telegram.org
egghead.io
w3schools.com
https://www.w3schools.com
https://www.typescriptlang.org`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}