package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(https?:\/\/)?(www\.)?\w+\.(com|org|io)`)
var str = `http://www.google.com
www.google.com
google.com
telegram.org
egghead.io
w3schools.com
https://www.w3schools.com
https://www.typescriptlang.org`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}