using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/)?(www\.)?\w+\.(com|org|io)";
string input = @"http://www.google.com
www.google.com
google.com
telegram.org
egghead.io
w3schools.com
https://www.w3schools.com
https://www.typescriptlang.org";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}