#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\([^()\n]*\)$|.*([()])[^()\n]*(?=\1)|[^()\n]*[()](?:[^()\n]*[()][^()\n]*[()])*[^()\n]*$|.*\([A-Z]\))\(?[A-Z](?: (?:and|or) \(?[A-Z]\)?)*$"
Local $sString = "A and B and C and D" & @CRLF & _
"(A or B) and C" & @CRLF & _
"(A or B or C) and D" & @CRLF & _
"(A or B or C or D) and E" & @CRLF & _
"A and (B or C) and D" & @CRLF & _
"A and (B or C) or (C and D)" & @CRLF & _
"A or (B and C)" & @CRLF & _
"(A and B) or (C and D)" & @CRLF & _
"A" & @CRLF & _
"" & @CRLF & _
"A and (B) and C" & @CRLF & _
"A and B)" & @CRLF & _
"A and B and C and " & @CRLF & _
"(A or B and C" & @CRLF & _
"(A or B or C) and D or" & @CRLF & _
"(A or B or C or D and E" & @CRLF & _
"A and or (B or C) and D" & @CRLF & _
"A and (B or (C and D)))" & @CRLF & _
"A (B and C)" & @CRLF & _
"(A and B) or C and D)" & @CRLF & _
"(A and B or C and D)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")