import re
regex = re.compile(r"^(?!\([^()\n]*\)$|.*([()])[^()\n]*(?=\1)|[^()\n]*[()](?:[^()\n]*[()][^()\n]*[()])*[^()\n]*$|.*\([A-Z]\))\(?[A-Z](?: (?:and|or) \(?[A-Z]\)?)*$", flags=re.MULTILINE)
test_str = ("A and B and C and D\n"
"(A or B) and C\n"
"(A or B or C) and D\n"
"(A or B or C or D) and E\n"
"A and (B or C) and D\n"
"A and (B or C) or (C and D)\n"
"A or (B and C)\n"
"(A and B) or (C and D)\n"
"A\n\n"
"A and (B) and C\n"
"A and B)\n"
"A and B and C and \n"
"(A or B and C\n"
"(A or B or C) and D or\n"
"(A or B or C or D and E\n"
"A and or (B or C) and D\n"
"A and (B or (C and D)))\n"
"A (B and C)\n"
"(A and B) or C and D)\n"
"(A and B or C and D)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")