#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)word1[^;\n]*(?:\R[^;\n]*?){0,5}word2"
Local $sString = " any random text word1 any random text" & @CRLF & _
" any random text any random text" & @CRLF & _
" any random text any random text" & @CRLF & _
" any random text any random text word2" & @CRLF & _
" any random text any random text;" & @CRLF & _
"" & @CRLF & _
" any random text word1 any random text" & @CRLF & _
" any random word2 text any random text word2" & @CRLF & _
" any random text any random text" & @CRLF & _
" any random text word2 any random text" & @CRLF & _
" any random text any random text word2 any random text;" & @CRLF & _
"" & @CRLF & _
" any random text word1 any random text" & @CRLF & _
" any random text any random text" & @CRLF & _
" any random text any random text" & @CRLF & _
" any random text any random text" & @CRLF & _
" any random text any random text any random text;" & @CRLF & _
" any random text any random text word2" & @CRLF & _
"" & @CRLF & _
" any random text word1 any random text" & @CRLF & _
" any random text any random text" & @CRLF & _
" any random text any random text" & @CRLF & _
" any random text any random text" & @CRLF & _
" any random text word2 any random text;" & @CRLF & _
"" & @CRLF & _
" any random text word1 any random text;" & @CRLF & _
" any random word2 text any random text word2" & @CRLF & _
" any random text any random text" & @CRLF & _
" any random text word2 any random text" & @CRLF & _
" any random text any random text word2 any random text;" & @CRLF & _
"" & @CRLF & _
" any random text word1 any random text;" & @CRLF & _
" any random text any random text" & @CRLF & _
" any random text any random text" & @CRLF & _
" any random text any random text" & @CRLF & _
" any random text word2 any random text;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")